Problem with H.Lividum

maddox

Arachnopeon
Joined
Dec 3, 2005
Messages
31
I bought the young female of Haplopelma lividum above two weeks ago. I think that quite good has conditions. The problem consists in this that she did not even begin still to dig. The whole time is on the surface. had someone the similar case ?? I ask for the opinion. ThanX a lot
 

mischaaussems

Arachnosquire
Old Timer
Joined
Nov 9, 2006
Messages
70
I've heard of this before, give it some time. Make shure the rest of the conditions (temp. humidity) good. You can also try to make a small beginning of a hole.
 

ballpython2

Arachnoprince
Old Timer
Joined
Feb 28, 2007
Messages
1,671
I bought the young female of Haplopelma lividum above two weeks ago. I think that quite good has conditions. The problem consists in this that she did not even begin still to dig. The whole time is on the surface. had someone the similar case ?? I ask for the opinion. ThanX a lot

Make sure she has enough so substrate...she could have tried to dig while you where sleeping maybe and thought it wasnt deep enough she she didnt bother.. you have her in a critter keeper or a tank or a tub?
 

ErikH

Arachnoangel
Old Timer
Joined
Mar 8, 2006
Messages
841
They sometimes take a while to start burrowing, I'm told. You can try pre-starting a burrow for her and see what happens.
 

Talkenlate04

ArachnoGod
Old Timer
Joined
Feb 13, 2006
Messages
8,662
This is normal. I have owned a few females that did not burrow or even try for up to a month, and then one day when I came home they were gone. Poof. So enjoy it while you can cause soon you will mostly see the tips of her legs if that.:D

Oh and if you keep the substrate a bit moist they love that.
 
Top