Might have made a mistake..

RoseT

Arachnosquire
Joined
Sep 20, 2010
Messages
87
Ok so Ive noticed my g rosea juvie has been in premolt for the last two weeks. She closed her burrow but since its against the acrylic container i can see through well..Well today I woke up and the view was now gone and what looked like the substrate had collapsed. I quickly starting removing the substrate thinking she was buried under there when I saw her poke through the substrate.well and active..still don't know if she was buried in it or what...Well now shes completely still... 9 hours later....Shes off color in deep post molt but it doesn't look like she will be anytime soon (no mat etc)...She could have been molting and I possibly could have disturbed it?...Juts kinda worried she wont molt due to stress issues and end up with a bad molt later..I feel bad.. =(
 

Abby

Arachnoknight
Old Timer
Joined
Sep 9, 2009
Messages
297
If there is molt mat, then maybe she wasn't molting when you did this.

Try not to disturb her and she'll molt when she's ready :)

Keep us posted :)
 

RoseT

Arachnosquire
Joined
Sep 20, 2010
Messages
87
Yeah hopefully cause shes as dark as my g pulchra juvie... maybe a bit lighter but damn, hopefully shes ok..Will keep you posted thanks.
 

gmrpnk21

Arachnobaron
Joined
Nov 1, 2010
Messages
319
Correct me if I am wrong guys, but I think as long as the subsrate wasn't too deep, she should be able to get herself out if it does fall in a bit on her. I keep looking at my vagan's burrow and wondering when I will see it again...
 
Top