1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mold after 3 days?!

Discussion in 'Tarantula Questions & Discussions' started by kgx2, Sep 11, 2019.

  1. kgx2

    kgx2 Arachnopeon

    3
    0
    1
    Florida
    Advertisement
    I just rehoused these little guys this past weekend due to an outbreak of fruit fly maggots in their enclosures and in 3 days i've got mold which was not an issue i was having previously. The substrate is just coco fiber, the plant is plastic and the moss is part of what came in one of Jamie's Sling starter kits (i'm not blaming her supplies for anything just give a full description) sprinkled on top. I'm pretty sure the mold shouldn't affect the Ts but should i rehouse them again? I don't want to over stress these little guys but i don't want them to fall ill either. As you can see from the pictures there should be adequate ventilation and air flow so i don't believe that is the issue. The only difference i can think of is these were moved to a new location after rehousing (partially due to the Fruit Flys) and were sitting on my dresser under my tv which is brand new and puts out little to no heat to where they sit (i checked as i was concerned about this myself and didn't want to cook them). The substrate is moist as they are slings but i wouldn't say it's sopping wet by any means.



    Mold 1.jpg Mold 3.jpg
     
  2. mack1855

    mack1855 Arachnobaron Arachnosupporter

    Ok,that looks like webbing to me.And I don't think mold happens in 3 days.
    What type of spood is this?
     
  3. kgx2

    kgx2 Arachnopeon

    3
    0
    1
    Florida
    This is my brachypelma boehmei. About 1/4in sling i've had about a month now.

    One of thing i forgot to mention is i live in Florida but the temps inside are always between 72 - 76.
     
  4. cold blood

    cold blood Moderator Staff Member

    Its common for mold to pop up in new enclosures simply because things tend to be holding a bit of moisture....but mold isnt something to worry about, and it would have to dominate the enclosure to prompt a re house.

    The easiest way to deal with mold is simply to pick it out and keep the enclosure clean.
     
    • Clarification Please Clarification Please x 1
  5. kgx2

    kgx2 Arachnopeon

    3
    0
    1
    Florida
    I'm starting to think it's due to the moss being to moist maybe? Here is a picture of another enclosure that has not been messed with since i put it together and put it's current resident in it who is currently molting (i hope) my Grammastola Pulchripes the largest of my current collection. You can see it looks like mold has formed on the moss here too and the T is currently burrowed under the substrait so this isn't webbing. Now this enclosure has not been moved for about a month as shortly after it went in it burrowed and closed it off so this was not in the same location of the first pictures and still there is moss.

    Mold 5 (2).jpg
     
  6. mack1855

    mack1855 Arachnobaron Arachnosupporter

    @cold blood ,that much mold in 3 days?.Really.I dose my T.blondi enclosure with H2O weekly,and don't have
    mold to that extent,if that's what this is.And hes been in the same enclosure for 9 months.
    I do have a lot of ventilation,i will add,but WOW.
     
  7. cold blood

    cold blood Moderator Staff Member

    Local weather plays a role....its warm and typically very humid in the OP's neck of the woods.

    For instance, I see nothing on new re houses here in winter (WI is exceptionally dry in winter as you can relate to), but in summer, during those exceptionally warm, humid times of the year, I deal with it regularly in new set ups...but it dies off in time, so unless it gets bad, I tend to just leave it run its course..

    Last week I had the heat on in my room, so it really dried out...this week its warm and stupid humid...I have spend time each of the past 3 days picking out bits of mold in sling enclosures that have been just fine since they were housed last month.