sick gravid emp

dangerprone69

Arachnoknight
Old Timer
Joined
Oct 18, 2004
Messages
280
This is new to me. I have a female emp in my colony's tank that's really acting strange. She also appears gravid. She hardly moves- just occasionally moving her legs a bit and her chelicerae(?). She's not dragging her tail, as I've seen scorps do when they're about to kick it. She doesn't appear to have anything physically wrong with her. Any ideas as to what may be wrong with her?
 

Thaedion

Arachnoangel
Old Timer
Joined
Nov 20, 2006
Messages
902
The things that come to mind are temps, humidity and mites. high 80°s F, high 80% humidity, mites that attach themselves to the scorp (mites took out a male of mine in the past)

Hope its not mites and GL
 

dangerprone69

Arachnoknight
Old Timer
Joined
Oct 18, 2004
Messages
280
I keep my Emps very hot and very humid. I don't think it's mites- I didn't see any on her. I had a problem in the colony a few months ago and took care of it using Hypoaspis sp. predatory mites and a complete cleaning of their environment. Haven't seen any mites since then.

What do you mean by "GL"? That didn't register with me.
 

Thaedion

Arachnoangel
Old Timer
Joined
Nov 20, 2006
Messages
902
I keep my Emps very hot and very humid. I don't think it's mites- I didn't see any on her. I had a problem in the colony a few months ago and took care of it using Hypoaspis sp. predatory mites and a complete cleaning of their environment. Haven't seen any mites since then.
Well I'm tapped out for any suggestions. So since it is a colony, and I'll assume none of the others are exhibiting the same symptoms, it'll just be a waiting game to see if it is just a 'passing phase' or not.

...What do you mean by "GL"? That didn't register with me.
GL is short hand for 'Good Luck'
 
Top