Mating Issue...pls help

Tang

Arachnopeon
Joined
Jun 10, 2010
Messages
6
Okay, both my Cyclosternum fasciatum were matured. The female molted 3 weeks ago and the MM already got his "boxing glove" and sperm web.(3 days ago):D

now, as I remembered, once saw a post from a source that I need to wait till the MM destroy the sperm web then only its ready...
Do I really need to wait till it destroy the web before the attemp to mate?
Will it be okay if I attemp to mate them?:?

This is the 1st mating attemp for my T's and I dont want anything went wrong because of me..:(

Thanks in advance...
 

xhexdx

ArachnoGod
Old Timer
Joined
Jul 20, 2007
Messages
5,362
You have to wait until the male builds a sperm web. Usually they will destroy the sperm web once they're done with it, which is what I think you are referring to.

There is no point in pairing them if the male has no sperm to deposit, unless you just want him to get the hint that there's a lady around. If you do pair them though, you risk the male being eaten without a successful pairing, so it's up to you.
 

Tang

Arachnopeon
Joined
Jun 10, 2010
Messages
6
You have to wait until the male builds a sperm web. Usually they will destroy the sperm web once they're done with it, which is what I think you are referring to.

Sperm web already made..:D

There is no point in pairing them if the male has no sperm to deposit, unless you just want him to get the hint that there's a lady around. If you do pair them though, you risk the male being eaten without a successful pairing, so it's up to you.
If it already made the sperm web it's ready.It doesn't have to destroy it.
Then theyre ready to go!! {D
 
Top